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Creating a PDF Form

Use Canvas from start to finish to create a printable PDF form, 

complete with graphics, hyperlinks, and editable text fields. 

As an owner of Canvas 8, you have at your command all of the tools that you will need to publish advanced 

PDF documents. Follow along with us in this tutorial and learn how you can deploy your work electronically from 

within Canvas without needing expensive additional third-party software or plug-ins..

A PDF (Portable Document Format) document is navigational, printable, compact, and viewable across a wide 

range of platforms. Once created, PDF files could be viewed on any platform. In other words, a PDF file, which 

is created on a Macintosh, can be downloaded from a Unix Web site and then read on a Windows platform.

Even though PDF continues to be increasingly popular in the publishing industry, the format is also widely used 

among Web content creators due to its ability to be viewed on demand without browser compatibility issues or 

downloading problems. 

Any Canvas document can be turned into a PDF document. In this example, we will use Canvas to create a 

custom PDF form which will contain graphics, hyperlinks, and editable text fields. This means that the Web 

page viewer will be able to enter text directly into the form and print it to a local printer. 

 

Preparing the Document

We start this tutorial by opening a new Canvas 

Illustration file. From within the New Document 

palette (File > New), choose Illustration as Type of 

Document. Next select US Letter as the Document 

size. When you are finished, click OK.



Creating a PDF Form (Continued)

will appear as an aqua line. 

 

Next, open the Rulers dialog box (Layout > Rulers 

from the main menu) and change the units of 

measurement to inches. Be certain that you adjust 

the Scale settings to 1 inch = 1 inch.

You need to do this because this form will be printed 

to a local printer. Therefore, we suggest that you 

use inches as the unit of measurement.

 

Setting Guides

We will be using Guides to help us to attain a 

visually pleasing and consistent border. The Guides 

function will also aid in the placement of text. 

Begin by displaying your rulers (Layout > Display > 

Show Rulers). Next you will need to align the rulers 

along the top and left side of your work area. 

Now place your pointer and click on the top ruler 

and drag the cursor down to where it will be slightly 

past the edge of the background paper. Your guide 

 

To ensure accuracy you can double-click on a Guide. 

Doing so will open the Guides dialog box. From 

within this palette you can enter the precise 

horizontal position of the guide.

In this example, we want a half-inch border around 

the document; therefore you need to enter 0.50 and 

press OK. 



    

Creating a PDF Form (Continued)

 

 

Using the online clip art, we enter a keyword, in 

this case "tooth", and press Search. When you find 

a suitable image, choose "Download File" and save 

it to your computer. Then you go to File > Place 

and locate the Canvas file you just downloaded 

and press OK. 

 

Use this method to place guides until you have a 

half-inch border completely around the page. When 

you have finished with this step, you should have 

two horizontal guides at 0.5 inches and 8 inches and 

two vertical guides at 0.5 inches and 11 inches.

Your document should look like the example on the 

right. 

Placing Images

We want to add some color to our PDF form. So using 

the Canvas Clip Art Collection available on CD, online, 

or through DenebaShare (Windows only), we will 

acquire an image of a tooth for our dentist's PDF 

form. 

If you are using the Canvas Clip Art CD, choose File > 

Place and locate the picture or Canvas image you 

wish to use and press OK. 
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Using DenebaShare (Windows only) open 

the DenebaShare Palette (Windows > 

Palette > DenebaShare) enter a keyword 

(e.g., tooth) and press search. When you 

see an image you want, click on it, and 

drag it into your working area.

 

The clip art image will appear as a group of objects. 

We are going to use it just the way it is; however, if 

you wanted to modify it, you would select the image 

and press Ctrl + U (Windows) or Command + U 

(Mac) to ungroup the objects. Once the objects are 

ungrouped, you could change the color, stroke, size, 

or even delete selections. 

Tip: To regroup your clip art, select all of the 

objects you wish to group and press Ctrl + G 

(Windows) or Command + G (Mac).

Ungrouped Objects

 

Once you have acquired and modified or resized 

your clip art image, drag it to the upper right hand 

corner of your document or wherever it is going to 

reside. 
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Adding Text

Next we are going to start adding text to our form. 

Begin by selecting the Text tool from the Toolbox and 

click inside the work area of your document. Then 

type, "Dental Credit Line."

 

 

You can change the font style very easily. Select the 

text, then double-click on the Text tool in the 

Toolbox. Doing so will open the Type palette. From 

within this palette, you can quickly adjust the 

appearance of your text. Size, font style, kerning, and 

baseline can be applied to any text that you have 

added to your document.

 

 

 

Because this text box will become our headline we 

would like to make certain that it stands out. 

Therefore we will modify the color of this text object. 

To do this you need to select the text box, then click 

on the Ink Fill icon, which is located at the bottom of 

the Toolbox, and select a color that you wish to apply 

to the text. 

Continue to add the text usually found on a form such 

as Last Name, Address, and Telephone. 



 

Aligning the Text

After you have created all of the text form fields 

that will be used in this form, you will realise 

that you need to align them into a uniform 

arrangement. 

You could do so manually. However the manual 

method is time consuming and lacks precision. 

We will show you how to use the Align tool to 

make short work of this chore.. 

Use the Selection tool and drag your text into 

the approximate position on the page that you 

would like them to be in the document. 
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Next, find all the text that will appear on the same 

line and select them. 

Since First Name and MI will be on the same line we 

will select them both and then choose Object > Align 

> Bottom. This will precisely align the text 

horizontally. After you have aligned your text, you will 

group it (Ctrl + G for Windows or Command + G in 

Mac) to keep it from becoming unaligned. 

Continue to align and group the rest of the text that 

will reside on the same plane. 



 

Your text should now be perfectly aligned and 

spaced. 

At this point, it is a good idea to group your text 

to keep it aligned (Ctrl + G in Windows or 

Command + G in Mac).

Creating a PDF Form (Continued)

 

Now we need to vertically align the rest of the 

text and space the lines evenly to give a uniform 

look. To do this, first select all the text you wish 

to align. Then open the Align palette (Object > 

Align and choose Show Palette). From this 

palette, select Vertical Inside Distribute and 

Horizontal Align Left, see example. When you are 

ready, press OK. 
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For the next step, you will need to choose the Pen Ink 

fill and select the color that you wish to use for the 

border of the text box. In this case, we selected a 

light blue color.

Adding Style

We would also like to enhance the appearance of our 

work. One easy method is to add a stylish border 

around some of the sections within the form. In 

addition to improving the visual appeal, this effort 

should promote a higher level of understanding. 

Prior to begining this step, make certain that you do 

not have a Canvas object selected. You may quickly 

ensure this by pressing the ESC key at least once or 

twice.

Next open the Ink Fill palette by clicking on the Ink 

Fill icon in your Toolbox and select no color from the 

Inks palette.



 

You may also want to create text borders for the 

text fields by using these same steps. 

 

 

Next, select the Rectangle tool from the Toolbox. 

Place the pointer in the upper left-hand corner of 

the document and click and drag across the text to 

create a border. 

Note: We suggest that you use the guides that you 

prepared in Step 1 of this tutorial to help you to 

align the new border.

 

You could use these same steps to create titles for 

each section.



 

Now you will need to place the pointer on the 

location where you would like to create the text 

box. Then click and drag the cursor across to 

create the text field. 

Continue to use this same technique to create 

editable text form fields for the rest of the form. 

Note: The text field borders have been 

purposely left out of this image to avoid 

confusion.

 

   

Adding Text Fields

At this stage you have finished with the form creation 

portion of the tutorial. 

For the next step, we are going to add editable text 

fields to our form. Doing so will allow the viewer the 

ability to enter text directly into your new form when 

it appears online. 

Without this ability, your Web visitor would have to 

print the blank form and write the information into 

blank fields. This could result in data that would be 

open to penmanship or other typographical errors 

thus rendering the data useless. 

By adding editable text field boxes to your form, you 

will allow the visitor to enter data directly into the 

form, prior to printing it out.

To add an editable text field, first select the Text 

Form Field tool from the Toolbox (see right). 
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Adding Hyperlinks

To assist people in reaching our site we have decided 

that we would like to add a hyperlink to our form. 

A hyperlink is a visible object such as text, a button, 

or graphic image that directs a visitor to another Web 

page on the Internet. 

This is an extremely useful feature that will assist the 

viewer should they need additional information.

 

 

 

To add a hyperlink begin by selecting 

the text that you wish to convert into a 

link. Do this by using the Text tool. 

Then, open the URL Attachment 

palette. Choose Window > Palettes > 

URL Tag from the main menu or click 

on the URL Tag icon just above the 

Docking Bar.

Inside the Assign window, type in the 

complete URL or Web address. Click the 

Assign button to convert the selected 

text into a hyperlink. 

Note: From this palette, you could also 

modify the Link Style. Examine the 

section detailing the URL Attachment 

palette in the Canvas Users' Guide for 

further information.

 

 

Your link will now appear as underlined blue text if 

you have decided to use the default settings as your 

style. 



Adding Field Properties

For the next step, we are going to define an 

Object Name for each text field using the 

Object Specs palette. 

To add specs, first open the Object Specs 

palette by choosing Object > Object Specs 

(see right). Select the Data tab.

Select the text field and then enter the 

name in the Object Name field. Click Apply.

We recommend this step if you eventually 

plan to have the PDF form submitted via e-

mail, script, or HTML. Once your document 

is saved as PDF, the Object Names appear 

in the text fields when the PDF form is 

opened in Adobe Acrobat.
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Saving Your Form

In our final step, we will save our Canvas document as a PDF 

document. To begin, choose File > Save As and enter a name for 

your PDF form. Choose a file location within your computer or 

network, and then select "Acrobat(*.PDF)" as the file format. Click 

Save.

After doing so, you will be presented with a number of options. 

Take a look at these capabilities so that you can better understand 

how PDF export process works. 

General Options 

Once a document is ready to be saved as a PDF, there are five 

general options: 

1.) Whenever Compress text and vectors is checked, all vector 

graphics will be compressed including a stream of text data.



 

2.) For PDFs that will pass through data channels that support only 7-bit data (such as e-mail), the Apply 

7-bit ASCII encoding option is recommended. 

3.) To ensure safe electronic transfer of documents, Embed font 

subsets will embed all TrueType and PostScript (Type 1) fonts used in a particular PDF document. Note: 

Embedding fonts will increase the size of the file; however, should your form be printed locally, all fonts will 

retain precise appearance and spacing.

4.) If exact character positioning is not necessary, then Optimize text output should be chosen to reduce a 

PDF's file size. 

5.) Canvas also offers the choice to convert files into either RGB or CMYK as the color mode. The CMYK color 

system is used in four-color process printing. The RGB color system is used for computer monitors. 

Creating a PDF Form (Continued)  

Images 

Most documents will contain photographs or rendered images of some sort. Regardless of the final destination - 

be it print or the web - you will need to decide on how the PDF export engine will handle these images. The 

standard resolution for online documentation is 72 dpi, while either 150 or 300 dpi is recommended for most 

print documents. 

It is also important to remember that the PDF export filter will compress all bitmap images. Lossless 

compression is available for technical drawings and illustrations, while JPEG compression is ideal for 

photographs.

Transparency 

When exporting documents that contain transparent objects, the PDF Options dialog box has two 

considerations: 

1.) Render mode lets you choose to render:

a.) only the objects that contain the transparency

b.) all of the transparent objects and those that touch them

c.) the entire page

2.) There is also the option to select CMYK or RGB as the Color mode. 

(Please see #5 of General Options for an explanation of these color modes.)



Specify halftone settings 

For print production purposes, there are a number of halftone shapes available from a drop-down menu. In 

addition, LPI will define the density of the grid in lines per inch and Angle will define the orientation of the grid. 

The particular choices for Shape and LPI/Angle depend upon specific pre-production needs. 

Since this is a simple downloadable form, we are just going to choose Compress text and Vectors, Embed Font 

Subsets, and set the resolution at 72 ppi. 

Once you have made your selections, press OK and you are done. 

 
Congratulations! The form is now ready for deployment. Because your work is now a PDF document it can 

easily used either on a Web site or e-mailed to a customer. As mentioned earlier, the advantage of creating this 

style of form is that your Web visitor has the ability of directly entering editable text that, when printed and 

mailed to you, can be easily read and understood. The alternative would be receiving hand-written forms that 

may be difficult decipher. In addition to your ability to receive vital information, you have also included a 

hyperlink into your document which will grant your customer the ablility to contact you for additional details. 

View the completed form. 
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Employer Name

Time Employed: Employment Phone:

Occupation:

Gross Employment Income: $

*Other Income: $
* INCOME NOTICE:  You need not disclose alimony, child support or separate maintenance income if you do not wish to have it considered as a basis for repaying this obligation.

A P P L I C A N T

First Name

Last Name

Date of Birth

Address

Residence Type:

If your credit references and/or credit history may be verified in any other name, please list those names here:

MI

Social Security No.

Apt.

City State Zip

Time at Residence:

Home Phone

Mortgage/Rent Payment: $

A P P L I C A N T Please tell us about YOURSELF

Please tell us about INCOME

Fill the form completely, sign it and to return it by fax: 555-555-2345 or regular mail to:  Dental Credit Services,
1055 Illusion Ave.  Miami, Fl 33175. For more information regarding Dental Credit services please visit our web-
site at http://www.dentalcreditline.com.  An incomplete form may result in the decline of your application.

Dental Credit is affiliated with other subsidiaries of DCL Corporation (”Affiliates”).  While you understand that the following authorization and instruction is not a
requirement to quality for an Account, in order that you may learn about the credit or other offerings of Affiliates, merchant or their agents, you authorize and Instruct
DCL USA to provide to Affiliates, merchant or their agents, any credit or other information about you that you have provided on this application or that DCL USA obtains
from any credit reporting agency or third party.  You understand that if you do not  want to authorize and instruct DCLL USA to provide such information to Affiliates,
merchant or their agents, you should call within 10 calendar days after the date of this Application.  DCL USA may begin to provide such information to Affiliates,
merchant or their agents if you do not call within those 10 days.  At any time therafter however, you may call the 800 telephone number and upon your request, DCL USA
will promptly cease any further provision of such information to Affiliates, merchant or their agents.  However, depending on when in a given month you call, you may
receive one solicitation after you call.

By signing below, you (1) hereby apply to Dental Credit Line USA (”DCL USA”) for a credit card account; (2) agree that everything stated on this application is true
to the best of your knowledge; (3) agree that DCL USA will retain this application or the information in this application whether or not it is approved; (4) make the
instructions concerning credit and other information above; (5) agree to the terms and conditions of the DCL USA Cardholder Agreement, which is available from DCL
USA, which will be given to you at the time your account is opened, and which is made a part of this application; (6) agree that we will have a purchase money security
interest in the goods purchased on your account; and (7) authorize and instruct DCL USA to request and receive credit information about you from any credit reporting
agency or third party.

X
Applicant’s Signature Date

Instructions to DCL USA to provide credit and other information

PLEASE
SIGN

http://www.deneba.com
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